Tłumaczenie wersji 2.5

Oto i mamy wer­sję 2.52.5.1 naszej uko­cha­nej plat­for­my blo­go­wej. Poni­żej pli­ki, któ­re pozwo­lą lepiej doga­dać się z pane­lem admi­ni­stra­cyj­nym w naszym ojczy­stym języ­ku.

  • [download#1]
  • [download#2]

Tłu­ma­cze­nie przy­go­to­wa­ne TYLKO w kodo­wa­niu UTF‑8, bar­dzo mi przy­kro, ale cza­so­wo nie daję rady przy­go­to­wać innych wer­sji, więc pro­szę nie pro­ście o to…

Tłu­ma­cze­nie jest wyko­na­ne w 99%, nie tłu­ma­czy­łem cał­ko­wi­cie tek­stów doty­czą­cych opcji wsta­wia­nia Fla­sh’a, bo chy­ba lepiej żeby zosta­ło to po angiel­sku (na razie i tak jest chy­ba jakiś pro­blem z wyświe­tla­niem tego dzia­łu w 2.5).

Komen­ta­rze, uwa­gi i pro­po­zy­cje jak zwy­kle bar­dzo mile widzia­ne, z racji dość szyb­kie­go wyda­nia nowej wer­sji tłu­ma­cze­nie koń­czy­łem w pew­nym pośpie­chu i mogą się zda­rzyć drob­ne lite­rów­ki, któ­re oczy­wi­ście będą popra­wia­ne na bie­żą­co.

73 odpowiedzi do “Tłumaczenie wersji 2.5”

  1. Dosko­na­le! Szyb­ka akcja, Kuba – bar­dzo Ci dzię­ku­ję. Tak zapy­tam tyl­ko – dla­cze­go „odwie­dĹş stro­nę” a nie „zobacz stro­nę”? Ale to tyl­ko moje jakieś przy­zwy­cza­je­nie.
    PS. Two­ja skór­ka zacna – nie będę się chwa­lił blo­giem, bo to auto­blog, ale link powi­nien do Cie­bie dotrzeć 😉

  2. Jesteś szyb­ki jak bły­ska­wi­ca :). Dzię­ku­ję. Jakoś zawsze koja­rzysz się z dobry­mi i szyb­ki­mi tłu­ma­cze­nia­mi 🙂

  3. @Bielack: tym razem potrak­to­wa­łem bar­dziej dosłow­nie „Visit Site”, odwie­dĹş jakoś bar­dziej pasu­je (w koń­cu na stro­nie raczej jeste­śmy gościem, a nie widzem).

  4. Witam! Fak­tycz­nie jesteś szyb­ki jak bły­ska­wi­ca. Nie spraw­dza­łem dokład­nie Two­je­go tłu­ma­cze­nia, ale z tego co pisa­łeś jesz­cze w poprzed­nim poście mogło wkraść się kil­ka błę­dów. Zabra­łem się za tłu­ma­cze­nie kil­ka dni temu i po zro­bie­niu TM z wer­sji 2.3.3 i auto­ma­tycz­nym prze­tłu­ma­cze­niu nowej wer­sji oka­za­ło się że jest strasz­nie dużo błę­dów. Wyni­ka­ją one z tego, że mecha­nizm poEdi­ta nie jest dosko­na­ły i np. fra­zy „view post” lub „edit post” to dla tego mecha­ni­zmu to samo. poEdit to nie tra­dos czy sdm. Mam nadzie­ję, że nie wpa­dłeś w pułap­kę. Pozdra­wiam!

  5. @Sławomir: auto­ma­tycz­ne tłu­ma­cze­nie jest kon­fi­gu­ro­wal­ne, tzn. defi­niu­jesz jak bar­dzo fra­zy mogą się róż­nić żeby pod­cho­dzi­ły pod to samo tłu­ma­cze­nie. Więc bynaj­mniej dwa ter­mi­ny któ­re wymie­ni­łeś to nie będzie to samo.

  6. To praw­da, ale pomi­mo odpo­wied­nich usta­wień (czy­li tyl­ko 100% mat­chy) korzy­sta­jąc z TM dosta­łem to samo tłu­ma­cze­nie dla fra­zy „Deta­il view” oraz „List view”, oraz zupeł­nie nie tra­fio­ne dla fra­zy „Mana­ge Com­ments”. Spraw­dzi­łem jed­nak jak to wyglą­da w Two­im przy­pad­ku i jest ok. Pozo­sta­je mi tyl­ko pogra­tu­lo­wać eks­pre­so­wej szyb­ko­ści. Pozdra­wiam!

  7. Nie wiem, pew­nie mnie uzna­cie za nooba. Ale spo­lsz­cze­nie mi nie cho­dzi. Przed insta­la­cją two­rzę kata­log lan­gu­ages we wp-con­tent i tam wrzu­cam pli­ki pl.mo i pl.po, póĹşniej edy­tu­je wp-config.php i po insta­la­cji powin­no być po pol­sku, a tu dalej po angiel­sku. 🙁

  8. „Publi­kuj natych­miast” pod­czas pisa­nia wpi­su – nie powin­no tutaj być coś w sty­lu „Edy­tuj czas opu­bli­ko­wa­nia postu”?

  9. I jesz­cze jed­na mała suge­stia – zamiast „Maga­zyn pli­ków” bar­dziej paso­wa­ło­by „Mul­ti­me­dia” 🙂 Jak jesz­cze się cze­goś doszu­kam, to napi­szę.

  10. „Pod­gląd­nij ten wpis” – znacz­nie lepiej brzmia­ło­by „Zobacz wpis”. Racja, pre­view to pod­gląd, ale „po pol­skie­mu” nie za bar­dzo mi to tutaj pasu­je.

  11. @rav: Publikuj natychmiast nie jest lin­kiem, tyl­ko stwier­dze­niem aktu­al­ne­go usta­wia­nia publi­ka­cji – któ­re możesz edy­to­wać kli­ka­jąc na edytuj.

    Multimedia to nie­zła suge­stia, jeśli wię­cej osób będzie mia­ło podob­ne zda­nie to może to zmie­nię w kolej­nej wer­sji tłu­ma­cze­nia.

    Sam zasta­na­wia­łem się czy nie prze­tłu­ma­czyć preview tak samo jak view, ale Zobacz wpis odno­si się do wpi­su już opu­bli­ko­wa­ne­go i wyda­je mi się waż­ne żeby zacho­wać to roz­róż­nie­nie.

  12. @rav: tak było w poprzed­niej wer­sji, ale teraz wszyst­kie przy­ci­ski odno­szą się do dzia­ła­nia użyt­kow­ni­ka (zobacz, edytuj, aktualizuj itp.) i ta for­ma po pro­stu nie pasu­je do resz­ty.

  13. Wyglą­da na to, że dzia­ła mi wszyst­ko bez pro­ble­mów. Mam nadzie­ję, że nie wyj­dą żad­ne kwiat­ki 🙂
    Kuba, dzię­ki za tłu­ma­cze­nie.

  14. Gdy­byś jesz­cze podał, gdzie wkle­ić te pli­ki, było­by ok. Wgra­łem do fol­de­ru lan­gu­ages w wp-con­tent i mi nie dzia­ła tłu­ma­cze­nie.

  15. Błąd:
    #: wp-admin/plugins.php:152
    msgid „Inac­ti­ve”
    msgstr „Nie­ak­tyw­ny”

    po pol­sku kla­sa też powin­na być inac­ti­ve.
    Czy wystar­czy zmie­nić plik .po żeby word­press poka­zał zmia­ny czy trze­ba też .mo? Coś mi nie chce poka­zać zmian po popraw­kach tyl­ko w .po.

  16. word­press wyciął naj­waż­niej­sze ale będzie wia­do­mo o co cho­dzi jak poszu­ka się tego miej­sca.

  17. dzię­ki. Jesz­cze taką drob­nost­kę wyła­pa­łem (dwie lite­rów­ki):
    „Wtycz­ki moga nad­pi­sa tę funk­cjo­nal­ność.”

    Btw. już wiem jak kom­pi­lo­wać .po 🙂

  18. Aha, czy­li tyl­ko u mnie nie dzia­ła? 🙁

    [Sat Apr 19 21:39:30 2008] [error] PHP War­ning: unpack() [function.unpack]: Type V: not eno­ugh input, need 4, have 0 in /home2/joemix/public_html/mayqueen/wp-includes/gettext.php on line 91

    Taki­mi błę­da­mi sypie server jak się włą­czy żeby było po pol­sku… no i stro­na cho­dzi bar­dzo wol­no lub wca­le 🙁

  19. Wie­le osób już podzię­ko­wa­ło, ale zro­bię to tak­że ja, bo to na praw­dę świet­na robo­ta. Dzię­ki!

  20. Zabie­ra­łem się za insta­la­cje WP, brak pol­skiej wer­sji skło­nił mnie do pró­by prze­siad­ki na B2Evo, a dzię­ki tobie wra­cam do WP.

  21. Całe szczę­ście, że cho­ciaż z WordPress’em nie muszę sam się męczyć (tłu­ma­czyć samo­dziel­nie).

    Dzię­ku­je i pozdra­wiam,
    Seba­stian

  22. Nie potra­fię spo­lo­ni­zo­wać Word­Pres­sa.
    Co robi­łem?
    Otóż:
    – Zain­sta­lo­wa­łem nowe­go Word­Pres­sa 2,5.
    – Ściągnąłem pli­ki polo­ni­za­cyj­ne: pl_PL.mo i pl_Pl.po.
    – Wyko­na­łem wszyst­ko zgod­nie z tym opi­sem ze stro­ny: http://www.audiophile.pl/n/57_instalacja_wordpress „Spo­lsz­cze­nie Word­Press”, więc:
    CYTAT
    Spo­lsz­cze­nie Word­Press
    1. W celu spo­lsz­cze­nia nale­ży pobrać pli­ki o nazwie: ( wpisz nazwy w wyszu­ki­war­ce )
    pl_PL.mo
    pl_PL.po
    2. Następ­nie trze­ba utwo­rzyć: /wp-inc­lu­de­s/lan­gu­age­s/ jak i zmie­nić nazwe pli­ków na:
    pl.mo
    pl.po
    3. Otwórz plik: wp-config.php i odszu­kaj: defi­ne (’WPLANG’, ‘’); zmień na :
    defi­ne (’WPLANG’, ‘pl’);
    4. Goto­we.

    Pro­szę o jakieś suge­stie.
    Pozdra­wiam.

  23. @Ryszard: trud­no coś pora­dzić bez obej­rze­nia two­je­go blo­ga, to może być jakiś szcze­gół, a może po pro­stu usta­wie­nia ser­we­ra (na nie­któ­rych ser­we­rach trze­ba wpro­wa­dzić małe zmia­ny do jądra WP)?

    Nazw pli­ków nie trze­ba zmie­niać, możesz je pozo­sta­wić i zde­fi­nio­wać pl_PL (moje instruk­cja).

  24. Ryszard: Pyta­nie brzmi, czy nie dzia­ła Ci panel admi­ni­stra­cyj­ny czy the­me? Jeśli masz usta­lo­ny stan­dar­do­wy nie­bie­ski the­me od Word­Press weĹş pod uwa­gę, że on nie jest prze­tłu­ma­czo­ny!

  25. sprawdz czy masz wiel­kosc nazw taka sama jak w pli­ku con­fig :]
    pl_PL jest w pli­ku a pli­ki spo­lsz­ce­nai cza­se sa pl_pl i juz nie dzia­ła ;]

  26. http://www.dobraidea.ovh.org/
    WP 2.5
    polo­ni­za­cja obej­mu­je caly panel admi­na, nato­miast data nadal jest 23rd, a nie 23, ponad­to spo­ro jest po angiel­sku. Kie­dy wybra­lem pol­ski jezyk zakla­da­jac kon­to na wordpress.com to tam wszyst­ko piek­nie spo­lsz­czo­ne.

    Insta­lo­wa­lem tak jak wyzej napi­sa­ne, kopio­wa­lem pli­ki i zmie­nia­lem wpis w con­fi­gu.

    O co cho­dzi ?

  27. Moty­wy gra­ficz­ne (skór­ki) trze­ba polo­ni­zo­wać osob­no. Może to jest pro­blem?

  28. ale uzy­wam tej super stan­dar­do­wej, a spraw­dza­lem plik .po i tam jest prze­tlu­ma­czo­ne np. Pages – Stro­ny, tak­ze nie wiem OCB

  29. Plik .po to jed­no, a odpo­wied­nie funk­cje tłu­ma­czą­ce (get­text) w kodzie stro­ny to co inne­go, jeśli fra­za nie jest „opa­ko­wa­na” w taką funk­cję to nie będzie prze­tłu­ma­czo­na

  30. w jaki spo­sób mam ścią­gnąć plik .PO?

    po klik­nię­ciu ładu­je mi się z krza­ka­mi w prze­glą­dar­ce, a save as nie dzia­ła bo jest skrypt php kto­ry liczy scia­gnie­cia…

    mozna pro­sic o napra­wie­nie tego?

  31. @bzx: Krza­ki to nic strasz­ne­go, po pro­stu Two­ja prze­glą­dar­ka nie roz­po­zna­ła kodo­wa­nia utf‑8, ale jak usta­wisz to kodo­wa­nie ręcz­nie to już się wszyst­ko wyświe­tla ok.

    Z dru­giej stro­ny masz rację, że takie pobie­ra­nie pli­ków to tro­chę nie­po­trzeb­na kom­pli­ka­cja, następ­ne pacz­ki będę umiesz­czał w zipie.

  32. „Admi­ni­stra­cja -> Wpi­sy” poka­zu­je cały nagłó­wek pli­ku po w nagłów­ku tabe­li. Jak będzie trze­ba to poka­że zdję­cie.

  33. To raczej pro­blem zwią­za­ny z usta­wie­nia­mi ser­we­ra, zda­rza się u nie­któ­rych. Musiał­byś poszu­kać w necie jakichś infor­ma­cji na temat zmia­ny kon­fi­gu­ra­cji ser­we­ra (może na forum WP?)

  34. Zba­da­łem spra­wę dogłęb­niej i oka­zu­je się, że jeden z plu­gi­nów dokle­ja sobie swój nagłó­wek do tabe­li i uży­wa do tego nastę­pu­ją­ce­go kodu:
    $arr[‚btm_post_actions’] = __(”);

    Taki pusty string w funk­cji __() „tłu­ma­czy” się na to co widzi­my jako nagłó­wek w pli­ku .po. To jest kwe­stia usta­wień ser­we­ra?

  35. W tym przy­pad­ku nie, po pro­stu dziw­ne zasto­so­wa­nie funk­cji get­text. W jakim celu ktoś uży­wa pustej funk­cji tłu­ma­cze­nia?? Podaj nazwę tej wtycz­ki bo jestem cie­kaw po co takie zasto­so­wa­nie.

  36. Po insta­la­cji pli­kow jezy­ko­wych, zgdo­nie z instruk­cja poj­wa­il sie pro­blem. Wszyst­kie opa­re­cja, kto­re zatwier­dza­lem: nowy wpis, stro­na, wid­get etc, kon­czy­ly sie bia­lym ekra­nem – pustym oczy­wi­scie.
    Wer­sja Word­Pres­sa 2.5.1
    Sytu­acja wro­ci­la do nor­my po ponow­nym wgra­niu wp-config.php

  37. @lipa: a pamię­tasz może co mia­łeś w poprzed­nim wp-con­fig? Bo to dość cie­ka­we zacho­wa­nie.

  38. pamie­tam, bo mam kopie i wgra­lem ja, gdy spo­tka­ly mnie te pro­ble­my 🙂
    Poni­zej wp-con­fig z usu­niet­mi dany­mi ser­we­ra

    ======================================================

    ten wpis defi­ne (‚WPLANG’, ‚pl’); zamie­ni­lem na ten, kto­ry zna­la­zlem na two­jej stro­nie i sie zacze­lo.
    Tlu­ma­cze­nie bylo, tyl­ko te scho­dy

  39. wkle­ilem wp-con­fig ale widze, ze go wycie­lo 🙁
    Jesli nie masz go, to napisz na maila, kto­ry poda­je.
    pozdra­wiam

Możliwość komentowania jest wyłączona.